忍者ブログ
Kossyの生活・仕事・ゲームのブログです^p^ 音ゲーは楽しい
×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。


ABR、ASBRおよび非OSPFドメインの基本的なネットワークを構築してみた。

・使用機器
Cisco1812×4台

・内容
バックボーンエリア以外に標準エリアを2つ作り、非OSPFドメインも設置し、再配送の設定を行う。
ルータR3がABRとASBRの2つの役割を持つ。

このネットワーク構成の設定および、各ルータのコンフィグとshow ip routeの出力結果確認。


拍手[0回]

まずはネットワーク構成図を作成。
ospf-1OSPF_ABR-ASBR構成図.png

次に各ルータの設定。

・ルータR1の設定
R1> enable
R1# conf t
R1(config)# hostname R1
R1(config)# interface fa 1
R1(config-if)# ip address 192.168.2.1 255.255.255.240
R1(config-if)# no shutdown
R1(config-if)# interface fa 0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# router ospf 100
R1(config-router)# router-id 200.1.1.250
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0        //バックボーンエリア
R1(config-router)# network 192.168.2.0 0.0.0.255 area 1        //標準エリア 1
R1(config-router)# end
R1# copy running-config startup-config

・ルータR2の設定
R2> enable
R2# conf t
R2(config)# hostname R2
R2(config)# interface fa 0
R2(config-if)# ip address 192.168.2.2 255.255.255.240
R2(config-if)# no shutdown
R2(config-if)# interface lo 0
R2(config-if)# ip address 192.168.3.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# ip ospf network point-to-point                ・・・①
R2(config-if)# exit
R2(config)# router ospf 100
R2(config-router)# router-id 200.1.1.20
R2(config-router)# network 192.168.2.0 0.0.0.255 area 1        //標準エリア 1
R2(config-router)# network 192.168.3.0 0.0.0.255 area 1        //標準エリア 1
R2(config-router)# end
R2# copy running-config startup-config

※①:Loopbackインタフェースでは、OSPFの仕様上サブネットマスクに関わらずホストルート(192.168.3.2/32)として扱うため、「ip ospf network point-to-point」を設定し、192.168.3.2/24でアドバタイズされるようにする。

・ルータR3の設定

R3> enable
R3# conf t
R3(config)# hostname R3
R3(config)# interface fa 0
R3(config-if)# ip address 192.168.1.3 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface fa 1
R3(config-if)# ip address 172.16.2.3 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface lo 0
R3(config-if)# ip address 192.168.5.3 255.255.255.192
R3(config-if)# no shutdown
R3(config-if)# ip ospf network point-to-point
R3(config-if)# exit
R3(config)# router ospf 100
R3(config-router)# redistribute rip subnets
R3(config-router)# router-id 200.1.1.10
R3(config-router)# network 192.168.1.0 0.0.0.255 area 0        //バックボーンエリア
R3(config-router)# network 192.168.5.0 0.0.0.255 area 2        //標準エリア 2
R3(config-router)# exit
R3(config)# router rip
R3(config-router)# version 2
R3(config-router)# redistribute ospf 100 metric 5            //再配送の設定(OSPF→RIP)
R3(config-router)# network 172.16.0.0                        //RIPのネットワークを指定
R3(config-router)# no auto-summary
R3(config-router)# end
R3# copy running-config startup-config

・ルータR4の設定
R4> enable
R4# conf t
R4(config)# hostname R4
R4(config-if)# interface fa 0
R4(config-if)# ip address 172.16.2.4 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# interface lo 0
R4(config-if)# ip address 172.16.1.4 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# exit
R4(config)# router rip
R4(config-router)# version 2
R4(config-router)# network 172.16.0.0                        //RIPのネットワークを指定
R4(config-router)# no auto-summary                        //集約化を無効
R4(config-router)# end
R4# copy running-config startup-config


上記設定後の「show ip route」および「show ip ospf」の出力結果は以下の通り。



<<< R1 >>>

----------------------------------------------------------------------------------------
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
O E2    172.16.1.0 [110/20] via 192.168.1.3, 00:06:27, FastEthernet0
O E2    172.16.2.0 [110/20] via 192.168.1.3, 00:06:27, FastEthernet0
     192.168.5.0/26 is subnetted, 1 subnets
O IA    192.168.5.0 [110/2] via 192.168.1.3, 00:06:27, FastEthernet0

C    192.168.1.0/24 is directly connected, FastEthernet0
     192.168.2.0/28 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet1
O    192.168.3.0/24 [110/2] via 192.168.2.2, 00:06:27, FastEthernet1

----------------------------------------------------------------------------------------
R1#sh ip ospf
 Routing Process "ospf 100" with ID 200.1.1.250
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 It is an area border router
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x01ED2C
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:11:16.200 ago
        SPF algorithm executed 7 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x042E0D
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:09:47.836 ago
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x03E75D
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0


<<< R2 >>>
----------------------------------------------------------------------------------------
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
O E2    172.16.1.0 [110/20] via 192.168.2.1, 00:13:49, FastEthernet0
O E2    172.16.2.0 [110/20] via 192.168.2.1, 00:13:49, FastEthernet0
     192.168.5.0/26 is subnetted, 1 subnets
O IA    192.168.5.0 [110/3] via 192.168.2.1, 00:13:49, FastEthernet0
O IA 192.168.1.0/24 [110/2] via 192.168.2.1, 00:13:49, FastEthernet0
     192.168.2.0/28 is subnetted, 1 subnets

C       192.168.2.0 is directly connected, FastEthernet0
C    192.168.3.0/24 is directly connected, Loopback0

----------------------------------------------------------------------------------------
R2#sh ip ospf
 Routing Process "ospf 100" with ID 200.1.1.20
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x01ED2C
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area 1
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm last executed 00:14:12.208 ago
        SPF algorithm executed 8 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x03E75D
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0


<<< R3 >>>
----------------------------------------------------------------------------------------
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
R       172.16.1.0 [120/1] via 172.16.2.4, 00:00:18, FastEthernet1

C       172.16.2.0 is directly connected, FastEthernet1
     192.168.5.0/26 is subnetted, 1 subnets
C       192.168.5.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, FastEthernet0
     192.168.2.0/28 is subnetted, 1 subnets
O IA    192.168.2.0 [110/2] via 192.168.1.1, 00:16:04, FastEthernet0
O IA 192.168.3.0/24 [110/3] via 192.168.1.1, 00:15:59, FastEthernet0


----------------------------------------------------------------------------------------
R3#sh ip ospf
 Routing Process "ospf 100" with ID 200.1.1.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution

 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x01ED2C
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:17:43.128 ago
        SPF algorithm executed 5 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x042E0D
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 2
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:18:36.124 ago
        SPF algorithm executed 3 times
        Area ranges are
        Number of LSA 4. Checksum Sum 0x014D03
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0


<<< R4 >>>
----------------------------------------------------------------------------------------
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Loopback0
C       172.16.2.0 is directly connected, FastEthernet0
     192.168.5.0/26 is subnetted, 1 subnets
R       192.168.5.0 [120/5] via 172.16.2.3, 00:00:09, FastEthernet0
R    192.168.1.0/24 [120/5] via 172.16.2.3, 00:00:09, FastEthernet0
     192.168.2.0/28 is subnetted, 1 subnets
R       192.168.2.0 [120/5] via 172.16.2.3, 00:00:09, FastEthernet0
R    192.168.3.0/24 [120/5] via 172.16.2.3, 00:00:09, FastEthernet0

----------------------------------------------------------------------------------------
R4#sh ip rip database
172.16.0.0/16    auto-summary
172.16.1.0/24    directly connected, Loopback0
172.16.2.0/24    directly connected, FastEthernet0
192.168.1.0/24    auto-summary
192.168.1.0/24
    [5] via 172.16.2.3, 00:00:08, FastEthernet0
192.168.2.0/24    auto-summary
192.168.2.0/28
    [5] via 172.16.2.3, 00:00:08, FastEthernet0
192.168.3.0/24    auto-summary
192.168.3.0/24
    [5] via 172.16.2.3, 00:00:08, FastEthernet0
192.168.5.0/24    auto-summary
192.168.5.0/26
    [5] via 172.16.2.3, 00:00:08, FastEthernet0


以上(´・ω・`)

→「OSPFネットワーク構築その2 スタブエリア」へ

PR

Comment
Name
Title
Mail
URL
Comment
Pass   Vodafone絵文字 i-mode絵文字 Ezweb絵文字
この記事へのトラックバック
この記事にトラックバックする:
[155] [154] [153] [152] [151] [150] [149] [148] [147] [146] [145
«  Back :   HOME   : Next  »
カウンター
カレンダー
06 2020/07 08
S M T W T F S
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
プロフィール

[Author] Kossy
[Steam_ID] Kossy

定時帰りそこそこ復活<(╹ヮ╹)>

最新コメント
[07/17 Kossy]
[07/17 カサハンラ]
[09/04 Kossy]
[09/03 おちんちん]
[08/04 testes]
[08/03 Kossy]
[08/02 testes]
マシンスペック

【メインPC】
[OS] Windows10 Pro 64bit
[CPU] Core i7-4790K @4GHz
[MEM] 16GB
[VGA] NVIDIA GeForce 970GTX
[マウス] DEATHADDER CHROMA
[PAD] SteelSeries Dex Gaming
[キーボード] 似非Realforce

【Webサーバー機】
[OS] CentOS 7.2
[CPU] Core2DUO E7500 2.93GHz
[MEM] 6GB
[HDD] 150GB
ブログ内検索
アーカイブ
バーコード
最新トラックバック
忍者ブログ [PR]