Kossyの生活・仕事・ゲームのブログです^p^ 音ゲーは楽しい
×
[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。
まずはバーチャルリンクを設定せずにルータ構築。
<エリア0 ルータR1の設定>
Router# conf t
Router(config)# hostname R1
R1(config)# interface fa 0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface lo 0
R1(config-if)# ip address 172.16.2.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# ip ospf network point-to-point
R1(config-if)# exit
R1(config)# router ospf 100
R1(config-router)# router-id 10.1.1.1
R1(config-router)# network 172.16.0.0 0.0.255.255 area 0
R1(config-router)# end
R1# copy running-config startup-config
<エリア1 ルータR2,R3の設定>
Router# conf t
Router(config)# hostname R2
R2(config)# interface fa 0
R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface fa 1
R2(config-if)# ip address 172.16.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface lo 0
R2(config-if)# ip address 192.168.2.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# ip ospf network point-to-point
R2(config-if)# exit
R2(config)# router ospf 100
R2(config-router)# router-id 10.2.2.2
R2(config-router)# network 192.168.0.0 0.0.255.255 area 1
R2(config-router)# network 172.16.0.0 0.0.255.255 area 0
R2(config-router)# end
R2# copy running-config startup-config
Router# conf t
Router(config)# hostname R3
R3(config)# interface fa 0
R3(config-if)# ip address 192.168.1.3 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface fa 1
R3(config-if)# ip address 10.1.1.3 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface lo 0
R3(config-if)# ip address 192.168.3.3 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# ip ospf network point-to-point
R3(config-if)# exit
R3(config)# router ospf 100
R3(config-router)# router-id 10.3.3.3
R3(config-router)# network 192.168.0.0 0.0.255.255 area 1
R3(config-router)# network 10.0.0.0 0.255.255.255 area 2
R3(config-router)# end
R3# copy running-config startup-config
<エリア2 ルータR4の設定>
Router# conf t
Router(config)# hostname R4
R4(config)# interface fa 0
R4(config-if)# ip address 10.1.1.4 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# interface lo 0
R4(config-if)# ip address 10.1.2.4 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# ip ospf network point-to-point
R4(config-if)# exit
R4(config)# router ospf 100
R4(config-router)# router-id 10.4.4.4
R4(config-router)# network 10.0.0.0 0.255.255.255 area 2
R4(config-router)# end
R4# copy running-config startup-config
この時点でルータR1~R4のルーティングテーブルを確認する。
<<< ルータR1 >>>
R1# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, FastEthernet0
C 172.16.2.0 is directly connected, Loopback0
O IA 192.168.1.0/24 [110/2] via 172.16.1.2, 00:02:30, FastEthernet0
O IA 192.168.2.0/24 [110/2] via 172.16.1.2, 00:02:45, FastEthernet0
O IA 192.168.3.0/24 [110/3] via 172.16.1.2, 00:02:35, FastEthernet0
<<< ルータR2 >>>
R2# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, FastEthernet1
O 172.16.2.0 [110/2] via 172.16.1.1, 00:03:30, FastEthernet1
C 192.168.1.0/24 is directly connected, FastEthernet0
C 192.168.2.0/24 is directly connected, Loopback0
O 192.168.3.0/24 [110/2] via 192.168.1.3, 00:03:20, FastEthernet0
<<< ルータR3 >>>
R3# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.1.0 [110/2] via 192.168.1.2, 00:04:45, FastEthernet0
O IA 172.16.2.0 [110/3] via 192.168.1.2, 00:04:45, FastEthernet0
10.0.0.0/24 is subnetted, 2 subnets
O 10.1.2.0 [110/2] via 10.1.1.4, 00:04:45, FastEthernet1
C 10.1.1.0 is directly connected, FastEthernet1
C 192.168.1.0/24 is directly connected, FastEthernet0
O 192.168.2.0/24 [110/2] via 192.168.1.2, 00:05:15, FastEthernet0
C 192.168.3.0/24 is directly connected, Loopback0
※ルータR3はエリア2と隣接してるため、全てのエリアのルートが載っている。
<<< ルータR4 >>>
R4# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, Loopback0
C 10.1.1.0 is directly connected, FastEthernet0
エリア2がバックボーンエリアに接続していない為、R4は他エリアルートを学習できていないのが分かる。
そこでバーチャルリンクを設定する。
R2(config)# router ospf 100
R2(config-router)# area 1 virtual-link 10.3.3.3
R3(config)# router ospf 100
R3(config-router)# area 1 virtual-link 10.2.2.2
設定後、show ip ospf virtual-linksで確認する。
<<< R2 >>>
R2# sh ip ospf virtual-links
Virtual Link OSPF_VL0 to router 10.3.3.3 is up ・・・①
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface FastEthernet0, Cost of using 1
Transmit Delay is 1 sec, State POINT_TO_POINT, ・・・②
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Adjacency State FULL (Hello suppressed) ・・・③
Index 2/3, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
<<< R3 >>>
R3# sh ip ospf virtual-links
Virtual Link OSPF_VL1 to router 10.2.2.2 is up ・・・①
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface FastEthernet0, Cost of using 1
Transmit Delay is 1 sec, State POINT_TO_POINT, ・・・②
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Adjacency State FULL (Hello suppressed) ・・・③
Index 1/3, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
◇R2、R3の出力結果から分かること
①ルータR2とR3間でバーチャルリンクが確立されアジャセンシーとなっている
②ポイントツーポイントのネットワークとなっている
③Helloパケットが抑制されている
そしてR3がバックボーンルータに所属できたのか確認してみる。
まずバーチャルリンク設定前のshow ip ospf出力結果。
R3# sh ip ospf
Routing Process "ospf 100" with ID 10.3.3.3
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Area 1
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:00:02.764 ago
SPF algorithm executed 11 times
Area ranges are
Number of LSA 5. Checksum Sum 0x034F7F
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:00:02.764 ago
SPF algorithm executed 9 times
Area ranges are
Number of LSA 3. Checksum Sum 0x02296D
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
エリア1と2のみで、バックボーンエリア0に所属できていないことが分かる。
次がバーチャルリンク設定後のshow ip ospf。
R3# sh ip ospf
Routing Process "ospf 100" with ID 10.3.3.3
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
It is an area border router
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
Number of areas transit capable is 1
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:01:47.268 ago
SPF algorithm executed 4 times
Area ranges are
Number of LSA 12. Checksum Sum 0x042A21
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 6
Flood list length 0
Area 1
Number of interfaces in this area is 2
This area has transit capability: Virtual Link Endpoint
Area has no authentication
SPF algorithm last executed 00:01:57.268 ago
SPF algorithm executed 8 times
Area ranges are
Number of LSA 7. Checksum Sum 0x0333CE
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:02:20.096 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 8. Checksum Sum 0x03B8E8
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
バーチャルリンクが確立された為、バックボーンエリアの情報がちゃんと載っている。
各ルータのshow ip routeの出力結果は以下の通り。
問題無く全エリアのルートが載っていることが分かる。
<<< R1 >>>
R1# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, FastEthernet0
C 172.16.2.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 2 subnets
O IA 10.1.2.0 [110/4] via 172.16.1.2, 00:04:26, FastEthernet0
O IA 10.1.1.0 [110/3] via 172.16.1.2, 00:04:26, FastEthernet0
O IA 192.168.1.0/24 [110/2] via 172.16.1.2, 00:04:26, FastEthernet0
O IA 192.168.2.0/24 [110/2] via 172.16.1.2, 00:04:26, FastEthernet0
O IA 192.168.3.0/24 [110/3] via 172.16.1.2, 00:04:27, FastEthernet0
<<< R2 >>>
R2# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, FastEthernet1
O 172.16.2.0 [110/2] via 172.16.1.1, 00:05:04, FastEthernet1
10.0.0.0/24 is subnetted, 2 subnets
O IA 10.1.2.0 [110/3] via 192.168.1.3, 00:05:04, FastEthernet0
O IA 10.1.1.0 [110/2] via 192.168.1.3, 00:05:04, FastEthernet0
C 192.168.1.0/24 is directly connected, FastEthernet0
C 192.168.2.0/24 is directly connected, Loopback0
O 192.168.3.0/24 [110/2] via 192.168.1.3, 00:05:04, FastEthernet0
<<< R3 >>>
R3# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
O 172.16.1.0 [110/2] via 192.168.1.2, 00:05:15, FastEthernet0
O 172.16.2.0 [110/3] via 192.168.1.2, 00:05:15, FastEthernet0
10.0.0.0/24 is subnetted, 2 subnets
O 10.1.2.0 [110/2] via 10.1.1.4, 00:05:35, FastEthernet1
C 10.1.1.0 is directly connected, FastEthernet1
C 192.168.1.0/24 is directly connected, FastEthernet0
O 192.168.2.0/24 [110/2] via 192.168.1.2, 00:05:25, FastEthernet0
C 192.168.3.0/24 is directly connected, Loopback0
<<< R4 >>>
R4# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.1.0 [110/3] via 10.1.1.3, 00:06:19, FastEthernet0
O IA 172.16.2.0 [110/4] via 10.1.1.3, 00:06:19, FastEthernet0
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, Loopback0
C 10.1.1.0 is directly connected, FastEthernet0
O IA 192.168.1.0/24 [110/2] via 10.1.1.3, 00:06:38, FastEthernet0
O IA 192.168.2.0/24 [110/3] via 10.1.1.3, 00:06:38, FastEthernet0
O IA 192.168.3.0/24 [110/2] via 10.1.1.3, 00:06:38, FastEthernet0
以上(´・ω・`)
「OSPFネットワーク構築その6 Virtual Link (2/2)」に続く
PR
Comment
カウンター
カレンダー
10 | 2024/11 | 12 |
S | M | T | W | T | F | S |
---|---|---|---|---|---|---|
1 | 2 | |||||
3 | 4 | 5 | 6 | 7 | 8 | 9 |
10 | 11 | 12 | 13 | 14 | 15 | 16 |
17 | 18 | 19 | 20 | 21 | 22 | 23 |
24 | 25 | 26 | 27 | 28 | 29 | 30 |
最新コメント
[07/17 Kossy]
[07/17 カサハンラ]
[09/04 Kossy]
[09/03 おちんちん]
[08/04 testes]
[08/03 Kossy]
[08/02 testes]
マシンスペック
【メインPC】
[OS] Windows11 Pro
[CPU] Core i5-10400 @2.9GHz
[MEM] 32GB
[VGA] NVIDIA GTX1660 SUPER
[マウス] Logicool M550L
[PAD] SteelSeries QcK 63004
[キーボード] Logicool K295
【Webサーバー機】
[Model] MINISFORUM N40
[OS] Rocky Linux
[CPU] Celeron N4020 @2.8GHz
[MEM] 4GB
[SSD] 64GB
カテゴリー
ブログ内検索
アーカイブ
最新トラックバック