Kossyの生活・仕事・ゲームのブログです^p^ 音ゲーは楽しい
×
[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。
OSPFと同じリンクステート型のルーティングプロトコル。
エリアという概念や、階層型ネットワーク構成、クラスレスのサポートなど、OSPFと似ています。
早速、Integrated IS-ISのネットワーク構成図を作成し、ネットワークを構築してみました。
・使用機器
Cisco1812×4台
ネットワーク構成図は以下の通り。
エリアという概念や、階層型ネットワーク構成、クラスレスのサポートなど、OSPFと似ています。
早速、Integrated IS-ISのネットワーク構成図を作成し、ネットワークを構築してみました。
・使用機器
Cisco1812×4台
ネットワーク構成図は以下の通り。
◇RT1の設定
RT1> enable
RT1# conf t
RT1(config)# hostname RT1
RT1(config)# router isis 100
RT1(config-router)# net 49.0001.001b.5370.9688.00
RT1(config-router)# exit
RT1(config)# interface fa 0
RT1(config-if)# ip address 10.1.1.1 255.255.255.0
RT1(config-if)# ip router isis 100
RT1(config-if)# no shutdown
RT1(config-if)# interface fa 1
RT1(config-if)# ip address 172.16.1.1 255.255.255.0
RT1(config-if)# ip router isis 100
RT1(config-if)# no shutdown
RT1(config-if)# end
RT1# copy running-config startup-config
◇RT2の設定
RT2> enable
RT2# conf t
RT2(config)# hostname RT2
RT2(config)# router isis 100
RT2(config-router)# net 49.0002.001b.2a97.53cc.00
RT2(config-router)# exit
RT2(config)# interface fa 0
RT2(config-if)# ip address 10.1.1.2 255.255.255.0
RT2(config-if)# ip router isis 100
RT2(config-if)# no shutdown
RT2(config-if)# interface fa 1
RT2(config-if)# ip address 192.168.1.2 255.255.255.0
RT2(config-if)# ip router isis 100
RT2(config-if)# no shutdown
RT2(config-if)# end
RT2# copy running-config startup-config
◇RT3の設定
RT3> enable
RT3# conf t
RT3(config)# hostname RT3
RT3(config)# router isis 100
RT3(config-router)# net 49.0001.001b.5492.809c.00
RT3(config-router)# is-type level-1
RT3(config-router)# exit
RT3(config)# interface fa 0
RT3(config-if)# ip address 172.16.1.3 255.255.255.0
RT3(config-if)# ip router isis 100
RT3(config-if)# no shutdown
RT3(config-if)# interface lo 0
RT3(config-if)# ip address 172.16.10.3 255.255.255.0
RT3(config-if)# ip router isis 100
RT3(config-if)# no shutdown
RT3(config-if)# end
RT3# copy running-config startup-config
◇RT4の設定
RT4> enable
RT4# conf t
RT4(config)# hostname RT4
RT4(config)# router isis 100
RT4(config-router)# net 49.0002.5492.699e.00
RT4(config-router)# is-type level-1
RT4(config-router)# exit
RT4(config)# interface fa 0
RT4(config-if)# ip address 192.168.1.4 255.255.255.0
RT4(config-if)# ip router isis 100
RT4(config-if)# no shutdown
RT4(config-if)# interface lo 0
RT4(config-if)# ip address 192.168.10.4 255.255.255.0
RT4(config-if)# ip router isis 100
RT4(config-if)# no shutdown
RT4(config-if)# end
RT4# copy running-config startup-config
OSPFと違うなあと感じたところは、NSAPアドレスの設定。
<RT1の設定を抜粋>
RT1(config-router)# net 49.0001.001b.5370.9688.00
ドット(.)で区切られてるけど、初見の時はなんじゃこりゃって思った。
簡単に説明すると以下の通り。
【49:AFI(Authority and Format)】
アドレスの形式を指定。
49で始まるものはプライベートアドレスを意味している。
【0001:Initial Domain ID(IDI)】
ドメインを識別。
OSPFで言えば、エリア0とか1とか。
この値によって同じエリアなのか、異なるエリアなのかが分かる。
【001b.5370.9688:システムID】
各OSIデバイスを識別。
CiscoIOSでは6バイトに固定されている。
この値はデバイスを識別するためのものなので、重複しないようにする。
ちなみに重複しないように今回はMACアドレスを割り当てました。
【00:NSEL】
最後の1バイトをNSELという。
TCP/IPでいうところのポート番号みたいなもの。
この値が00だと、ポート指定無し=そのデバイス自体を指定している、ということになる。
ちなみに、NSAPアドレスの最後の1バイト(NSEL)が00になっているものを、NET(Network Entity Title)という。
また、SPF計算でもこのNETを使い、IS(=ルータ)を識別しています。
設定後のルータのIS-ISの設定など確認。
<<< RT1 >>>
----------------------------------------------------------------------------------
RT1# sh clns protocol
IS-IS Router: 100
System Id: 001B.5370.9688.00 IS-Type: level-1-2
Manual area address(es):
49.0001
Routing for area address(es):
49.0001
Interfaces supported by IS-IS:
FastEthernet1 - IP
FastEthernet0 - IP
Redistribute:
static (on by default)
Distance for L2 CLNS routes: 110
RRR level: none
Generate narrow metrics: level-1-2
Accept narrow metrics: level-1-2
Generate wide metrics: none
Accept wide metrics: none
Integrated IS-ISに関するサマリー情報を確認。
エリアアドレスは49.0001。
ルーティングレベルはRT2と異なるエリア間ルーティングが発生しているため、“level-1-2”となっている。
----------------------------------------------------------------------------------
RT1# show clns neighbors
System Id Interface SNPA State Holdtime Type Protocol
RT3 Fa1 001b.5492.809c Up 7 L1 IS-IS
RT2 Fa0 001b.2a97.53cc Up 23 L2 IS-IS
ネイバー情報の確認。
----------------------------------------------------------------------------------
RT1# show clns interface
FastEthernet0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 29 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: RT1.01
DR ID: 0000.0000.0000.00
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: RT1.01
DR ID: RT1.01
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 2 seconds
Next IS-IS LAN Level-2 Hello in 2 seconds
FastEthernet1 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 20 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: RT3.01
DR ID: RT3.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: RT1.02
DR ID: 0000.0000.0000.00
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 3 seconds
Next IS-IS LAN Level-2 Hello in 4 seconds
IS-ISが有効になっているインタフェースの確認。
FastEthernet 0および1で有効になっていることが分かる。
----------------------------------------------------------------------------------
RT1# show isis topology
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
RT1 --
RT3 10 RT3 Fa1 001b.5492.809c
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
RT2 10 RT2 Fa0 001b.2a97.53cc
RT1 --
レベル1/レベル2の最短ルートの確認。
CLNS(Connectionless Network Service)ネイバー(ESおよびIS)と、ネイバーのSNPAが分かる。
※ES:End System(ホスト)
※IS:Intermediate System(ルータ)
※SNPA(Subnetowrk Point of Attachment):ネイバールータのレイヤ2アドレスを示したもの。イーサネットなどのLANではMACアドレスが用いられる。
----------------------------------------------------------------------------------
RT1# show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
RT2.00-00 0x00000010 0xBDD8 540 0/0/0
RT1.00-00 * 0x00000019 0x68F4 835 1/0/0
RT1.01-00 * 0x00000003 0x28D2 0 (738) 0/0/0
RT4.00-00 0x00000005 0x8AD7 574 0/0/0
RT4.01-00 0x00000001 0xEA5C 4 0/0/0
RT3.00-00 0x00000007 0x3F51 892 0/0/0
RT3.01-00 0x00000003 0xDF3A 569 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
RT2.00-00 0x00000020 0x7E3F 872 0/0/0
RT1.00-00 * 0x00000024 0x3BD7 835 0/0/0
RT1.01-00 * 0x00000004 0x6280 1192 0/0/0
RT3.00-00 0x00000005 0xF0E7 0 (877) 0/0/0
RT3.01-00 0x00000001 0xF1E9 0 (863) 0/0/0
IS-ISのLSDB(Link State Database)の確認。
----------------------------------------------------------------------------------
RT1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
i L2 192.168.10.0/24 [115/30] via 10.1.1.2, FastEthernet0
172.16.0.0/24 is subnetted, 2 subnets
i L1 172.16.10.0 [115/20] via 172.16.1.3, FastEthernet1
C 172.16.1.0 is directly connected, FastEthernet1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0
i L2 192.168.1.0/24 [115/20] via 10.1.1.2, FastEthernet0
RT1のIPルーティング情報の確認。
i L1:IS-ISのレベル1ルーティングを示している。同じエリア内なので、ネイバーのRT3側でレベルを1に設定した。
i L2:IS-ISのレベル2ルーティングを示している。異なるエリア間のルーティングで使用。
ルーティングレベルは、デフォルト設定だとLevel1/2の両方が設定されている。
----------------------------------------------------------------------------------
RT1# show ip protocols
Routing Protocol is "isis 100"
Invalid after 0 seconds, hold down 0, flushed after 0
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: isis
Address Summarization:
None
Maximum path: 4
Routing for Networks:
FastEthernet0
FastEthernet1
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 115 00:25:08
192.168.10.4 115 00:08:31
192.168.1.2 115 00:01:15
172.16.10.3 115 00:00:32
172.16.1.3 115 00:26:07
Distance: (default is 115)
RT1のIPサマリー情報の確認。
IS-ISのAdministrative Distanceのデフォルト値は115。
ちなみにOSPFは110で、RIPは120がデフォルト値。
<<< RT4 >>>
----------------------------------------------------------------------------------
RT4# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.1.2 to network 0.0.0.0
C 192.168.10.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
i L1 10.1.1.0 [115/20] via 192.168.1.2, FastEthernet0
C 192.168.1.0/24 is directly connected, FastEthernet0
i*L1 0.0.0.0/0 [115/10] via 192.168.1.2, FastEthernet0
レベル1ルーティングのみを行うルータで、OSPFでいうところのトータリースタブエリアの内部ルータに相当する。
従って、エリア外へのルートは全てデフォルトルートを宛先とする。
RT2とRT3は割愛ヽ(`Д´)ノ
RT1とRT4の対になってて同じような設定だし。
今回の勉強でIS-ISの設定方法とか、エリアの概念は分かった。
次はアドレスの集約をしてみてIS-ISに関しては終了かな(´・ω・`)
RT1> enable
RT1# conf t
RT1(config)# hostname RT1
RT1(config)# router isis 100
RT1(config-router)# net 49.0001.001b.5370.9688.00
RT1(config-router)# exit
RT1(config)# interface fa 0
RT1(config-if)# ip address 10.1.1.1 255.255.255.0
RT1(config-if)# ip router isis 100
RT1(config-if)# no shutdown
RT1(config-if)# interface fa 1
RT1(config-if)# ip address 172.16.1.1 255.255.255.0
RT1(config-if)# ip router isis 100
RT1(config-if)# no shutdown
RT1(config-if)# end
RT1# copy running-config startup-config
◇RT2の設定
RT2> enable
RT2# conf t
RT2(config)# hostname RT2
RT2(config)# router isis 100
RT2(config-router)# net 49.0002.001b.2a97.53cc.00
RT2(config-router)# exit
RT2(config)# interface fa 0
RT2(config-if)# ip address 10.1.1.2 255.255.255.0
RT2(config-if)# ip router isis 100
RT2(config-if)# no shutdown
RT2(config-if)# interface fa 1
RT2(config-if)# ip address 192.168.1.2 255.255.255.0
RT2(config-if)# ip router isis 100
RT2(config-if)# no shutdown
RT2(config-if)# end
RT2# copy running-config startup-config
◇RT3の設定
RT3> enable
RT3# conf t
RT3(config)# hostname RT3
RT3(config)# router isis 100
RT3(config-router)# net 49.0001.001b.5492.809c.00
RT3(config-router)# is-type level-1
RT3(config-router)# exit
RT3(config)# interface fa 0
RT3(config-if)# ip address 172.16.1.3 255.255.255.0
RT3(config-if)# ip router isis 100
RT3(config-if)# no shutdown
RT3(config-if)# interface lo 0
RT3(config-if)# ip address 172.16.10.3 255.255.255.0
RT3(config-if)# ip router isis 100
RT3(config-if)# no shutdown
RT3(config-if)# end
RT3# copy running-config startup-config
◇RT4の設定
RT4> enable
RT4# conf t
RT4(config)# hostname RT4
RT4(config)# router isis 100
RT4(config-router)# net 49.0002.5492.699e.00
RT4(config-router)# is-type level-1
RT4(config-router)# exit
RT4(config)# interface fa 0
RT4(config-if)# ip address 192.168.1.4 255.255.255.0
RT4(config-if)# ip router isis 100
RT4(config-if)# no shutdown
RT4(config-if)# interface lo 0
RT4(config-if)# ip address 192.168.10.4 255.255.255.0
RT4(config-if)# ip router isis 100
RT4(config-if)# no shutdown
RT4(config-if)# end
RT4# copy running-config startup-config
OSPFと違うなあと感じたところは、NSAPアドレスの設定。
<RT1の設定を抜粋>
RT1(config-router)# net 49.0001.001b.5370.9688.00
ドット(.)で区切られてるけど、初見の時はなんじゃこりゃって思った。
簡単に説明すると以下の通り。
【49:AFI(Authority and Format)】
アドレスの形式を指定。
49で始まるものはプライベートアドレスを意味している。
【0001:Initial Domain ID(IDI)】
ドメインを識別。
OSPFで言えば、エリア0とか1とか。
この値によって同じエリアなのか、異なるエリアなのかが分かる。
【001b.5370.9688:システムID】
各OSIデバイスを識別。
CiscoIOSでは6バイトに固定されている。
この値はデバイスを識別するためのものなので、重複しないようにする。
ちなみに重複しないように今回はMACアドレスを割り当てました。
【00:NSEL】
最後の1バイトをNSELという。
TCP/IPでいうところのポート番号みたいなもの。
この値が00だと、ポート指定無し=そのデバイス自体を指定している、ということになる。
ちなみに、NSAPアドレスの最後の1バイト(NSEL)が00になっているものを、NET(Network Entity Title)という。
また、SPF計算でもこのNETを使い、IS(=ルータ)を識別しています。
設定後のルータのIS-ISの設定など確認。
<<< RT1 >>>
----------------------------------------------------------------------------------
RT1# sh clns protocol
IS-IS Router: 100
System Id: 001B.5370.9688.00 IS-Type: level-1-2
Manual area address(es):
49.0001
Routing for area address(es):
49.0001
Interfaces supported by IS-IS:
FastEthernet1 - IP
FastEthernet0 - IP
Redistribute:
static (on by default)
Distance for L2 CLNS routes: 110
RRR level: none
Generate narrow metrics: level-1-2
Accept narrow metrics: level-1-2
Generate wide metrics: none
Accept wide metrics: none
Integrated IS-ISに関するサマリー情報を確認。
エリアアドレスは49.0001。
ルーティングレベルはRT2と異なるエリア間ルーティングが発生しているため、“level-1-2”となっている。
----------------------------------------------------------------------------------
RT1# show clns neighbors
System Id Interface SNPA State Holdtime Type Protocol
RT3 Fa1 001b.5492.809c Up 7 L1 IS-IS
RT2 Fa0 001b.2a97.53cc Up 23 L2 IS-IS
ネイバー情報の確認。
----------------------------------------------------------------------------------
RT1# show clns interface
FastEthernet0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 29 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: RT1.01
DR ID: 0000.0000.0000.00
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: RT1.01
DR ID: RT1.01
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 2 seconds
Next IS-IS LAN Level-2 Hello in 2 seconds
FastEthernet1 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 20 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: RT3.01
DR ID: RT3.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: RT1.02
DR ID: 0000.0000.0000.00
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 3 seconds
Next IS-IS LAN Level-2 Hello in 4 seconds
IS-ISが有効になっているインタフェースの確認。
FastEthernet 0および1で有効になっていることが分かる。
----------------------------------------------------------------------------------
RT1# show isis topology
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
RT1 --
RT3 10 RT3 Fa1 001b.5492.809c
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
RT2 10 RT2 Fa0 001b.2a97.53cc
RT1 --
レベル1/レベル2の最短ルートの確認。
CLNS(Connectionless Network Service)ネイバー(ESおよびIS)と、ネイバーのSNPAが分かる。
※ES:End System(ホスト)
※IS:Intermediate System(ルータ)
※SNPA(Subnetowrk Point of Attachment):ネイバールータのレイヤ2アドレスを示したもの。イーサネットなどのLANではMACアドレスが用いられる。
----------------------------------------------------------------------------------
RT1# show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
RT2.00-00 0x00000010 0xBDD8 540 0/0/0
RT1.00-00 * 0x00000019 0x68F4 835 1/0/0
RT1.01-00 * 0x00000003 0x28D2 0 (738) 0/0/0
RT4.00-00 0x00000005 0x8AD7 574 0/0/0
RT4.01-00 0x00000001 0xEA5C 4 0/0/0
RT3.00-00 0x00000007 0x3F51 892 0/0/0
RT3.01-00 0x00000003 0xDF3A 569 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
RT2.00-00 0x00000020 0x7E3F 872 0/0/0
RT1.00-00 * 0x00000024 0x3BD7 835 0/0/0
RT1.01-00 * 0x00000004 0x6280 1192 0/0/0
RT3.00-00 0x00000005 0xF0E7 0 (877) 0/0/0
RT3.01-00 0x00000001 0xF1E9 0 (863) 0/0/0
IS-ISのLSDB(Link State Database)の確認。
----------------------------------------------------------------------------------
RT1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
i L2 192.168.10.0/24 [115/30] via 10.1.1.2, FastEthernet0
172.16.0.0/24 is subnetted, 2 subnets
i L1 172.16.10.0 [115/20] via 172.16.1.3, FastEthernet1
C 172.16.1.0 is directly connected, FastEthernet1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0
i L2 192.168.1.0/24 [115/20] via 10.1.1.2, FastEthernet0
RT1のIPルーティング情報の確認。
i L1:IS-ISのレベル1ルーティングを示している。同じエリア内なので、ネイバーのRT3側でレベルを1に設定した。
i L2:IS-ISのレベル2ルーティングを示している。異なるエリア間のルーティングで使用。
ルーティングレベルは、デフォルト設定だとLevel1/2の両方が設定されている。
----------------------------------------------------------------------------------
RT1# show ip protocols
Routing Protocol is "isis 100"
Invalid after 0 seconds, hold down 0, flushed after 0
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: isis
Address Summarization:
None
Maximum path: 4
Routing for Networks:
FastEthernet0
FastEthernet1
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 115 00:25:08
192.168.10.4 115 00:08:31
192.168.1.2 115 00:01:15
172.16.10.3 115 00:00:32
172.16.1.3 115 00:26:07
Distance: (default is 115)
RT1のIPサマリー情報の確認。
IS-ISのAdministrative Distanceのデフォルト値は115。
ちなみにOSPFは110で、RIPは120がデフォルト値。
<<< RT4 >>>
----------------------------------------------------------------------------------
RT4# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.1.2 to network 0.0.0.0
C 192.168.10.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
i L1 10.1.1.0 [115/20] via 192.168.1.2, FastEthernet0
C 192.168.1.0/24 is directly connected, FastEthernet0
i*L1 0.0.0.0/0 [115/10] via 192.168.1.2, FastEthernet0
レベル1ルーティングのみを行うルータで、OSPFでいうところのトータリースタブエリアの内部ルータに相当する。
従って、エリア外へのルートは全てデフォルトルートを宛先とする。
RT2とRT3は割愛ヽ(`Д´)ノ
RT1とRT4の対になってて同じような設定だし。
今回の勉強でIS-ISの設定方法とか、エリアの概念は分かった。
次はアドレスの集約をしてみてIS-ISに関しては終了かな(´・ω・`)
PR
Comment
カウンター
カレンダー
10 | 2024/11 | 12 |
S | M | T | W | T | F | S |
---|---|---|---|---|---|---|
1 | 2 | |||||
3 | 4 | 5 | 6 | 7 | 8 | 9 |
10 | 11 | 12 | 13 | 14 | 15 | 16 |
17 | 18 | 19 | 20 | 21 | 22 | 23 |
24 | 25 | 26 | 27 | 28 | 29 | 30 |
最新コメント
[07/17 Kossy]
[07/17 カサハンラ]
[09/04 Kossy]
[09/03 おちんちん]
[08/04 testes]
[08/03 Kossy]
[08/02 testes]
マシンスペック
【メインPC】
[OS] Windows11 Pro
[CPU] Core i5-10400 @2.9GHz
[MEM] 32GB
[VGA] NVIDIA GTX1660 SUPER
[マウス] Logicool M550L
[PAD] SteelSeries QcK 63004
[キーボード] Logicool K295
【Webサーバー機】
[Model] MINISFORUM N40
[OS] Rocky Linux
[CPU] Celeron N4020 @2.8GHz
[MEM] 4GB
[SSD] 64GB
カテゴリー
ブログ内検索
アーカイブ
最新トラックバック